Commit f78adf7e authored by S Anand's avatar S Anand

ENH: add ES6 module support

parent 7cf80214
Pipeline #93548 passed with stage
in 2 minutes and 15 seconds
# Change log
- `0.17.2`:
- Expose ES6 modules in `modules.js`. Allows `require('g1')` in node
- `0.17.1`:
- [$.template](docs/template.md) exposes variables `$node` (the source node)
and `$data` (its `data-` attributes)
......
{
"name": "g1",
"version": "0.17.1",
"version": "0.17.2",
"description": "Gramex 1.x interaction library",
"license": "MIT",
"author": "S Anand <s.anand@gramener.com>",
......@@ -37,6 +37,7 @@
"d3": "4",
"d3-scale-chromatic": "1",
"deepmerge": "2",
"eclint": "2",
"es6-promise": "4",
"eslint": "4",
"events-polyfill": "2",
......
/* globals $, _ */
export function ajaxchain(request, $self, requests, responses) {
$self = $self || $('<div>')
requests = requests || []
......
/* globals d3 */
import { scale } from './scale.js'
import { parseSvg } from './parsetransform.js'
export { sanddance }
......
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment