Commit e0fd867f authored by Tejesh P's avatar Tejesh P
Browse files

ENH: move external dependencies to dev dependencies in package.json with major versions

parent 1842cc79
Pipeline #69262 passed with stage
in 2 minutes and 11 seconds
This diff is collapsed.
......@@ -24,24 +24,26 @@
"babel-plugin-transform-runtime": "6",
"babel-preset-env": "1",
"babelrc-rollup": "3",
"bootstrap": "4.1",
"bootstrap-select": "1.13",
"browserify": "14",
"component-emitter": "1",
"d3": "4",
"d3-scale-chromatic": "1",
"deepmerge": "^2.1.1",
"deepmerge": "2",
"es6-promise": "4",
"eslint": "4",
"events-polyfill": "^2.0.7",
"events-polyfill": "2",
"express": "4",
"faucet": "0.0",
"font-awesome": "4",
"glob": "7.1",
"html-minifier": "3",
"is-plain-object": "^2.0.4",
"is-plain-object": "2",
"jquery": "3",
"json2module": "0.0",
"leaflet": "1.3",
"lodash": "^4.17.10",
"lodash": "4",
"moment": "2",
"numeral": "2",
"popper.js": "1",
......@@ -60,9 +62,5 @@
"topojson": "3",
"uglify-js": "3",
"unfetch": "3"
},
"dependencies": {
"bootstrap": "^4.1.3",
"bootstrap-select": "^1.13.1"
}
}
......@@ -738,13 +738,15 @@ boom@2.x.x:
dependencies:
hoek "2.x.x"
bootstrap-select@^1.13.1:
version "1.13.1"
resolved "https://registry.yarnpkg.com/bootstrap-select/-/bootstrap-select-1.13.1.tgz#f59c02926fb5ac6356b9d1cdbc5384c2f013d9ba"
bootstrap-select@1.13:
version "1.13.3"
resolved "https://registry.yarnpkg.com/bootstrap-select/-/bootstrap-select-1.13.3.tgz#77f62b72c69339227753b3879cec036039dcb4d9"
integrity sha512-XzMwLFqRJQb142zR3ev57bZl66/h/RRguMODVfH0w2YTcJrqU+VCO6CserMxsVF4JE6hX9O99MQGZxgWZiitfg==
bootstrap@^4.1.3:
bootstrap@4.1:
version "4.1.3"
resolved "https://registry.yarnpkg.com/bootstrap/-/bootstrap-4.1.3.tgz#0eb371af2c8448e8c210411d0cb824a6409a12be"
integrity sha512-rDFIzgXcof0jDyjNosjv4Sno77X4KuPeFxG2XZZv1/Kc8DRVGVADdoQyyOVDwPqL36DDmtCQbrpMCqvpPLJQ0w==
brace-expansion@^1.1.7:
version "1.1.11"
......@@ -1445,9 +1447,10 @@ deep-is@~0.1.3:
version "0.1.3"
resolved "https://registry.yarnpkg.com/deep-is/-/deep-is-0.1.3.tgz#b369d6fb5dbc13eecf524f91b070feedc357cf34"
deepmerge@^2.1.1:
version "2.1.1"
resolved "https://registry.yarnpkg.com/deepmerge/-/deepmerge-2.1.1.tgz#e862b4e45ea0555072bf51e7fd0d9845170ae768"
deepmerge@2:
version "2.2.1"
resolved "https://registry.yarnpkg.com/deepmerge/-/deepmerge-2.2.1.tgz#5d3ff22a01c00f645405a2fbc17d0778a1801170"
integrity sha512-R9hc1Xa/NOBi9WRVUWg19rl1UB7Tt4kuPd+thNJgFZoxXsTz7ncaPaeIm+40oSGuP33DfMb4sZt1QIGiJzC4EA==
define-properties@^1.1.2:
version "1.1.2"
......@@ -1724,9 +1727,10 @@ etag@~1.8.1:
version "1.8.1"
resolved "https://registry.yarnpkg.com/etag/-/etag-1.8.1.tgz#41ae2eeb65efa62268aebfea83ac7d79299b0887"
events-polyfill@^2.0.7:
version "2.0.7"
resolved "https://registry.yarnpkg.com/events-polyfill/-/events-polyfill-2.0.7.tgz#8bb9477b42c1e205538c0ace92592066551e9e2e"
events-polyfill@2:
version "2.1.0"
resolved "https://registry.yarnpkg.com/events-polyfill/-/events-polyfill-2.1.0.tgz#65b4ad0d3a34680a06c1e737d6f1db0b855bb135"
integrity sha512-svwu8bsj6sMolrlTVVGWqVDYOGFOkMzL7puF0o0ASv7q24CCGrrGyhyxme2kZyZZhDn/mqyDWNIzvfYO0+8vFA==
events@~1.1.0:
version "1.1.1"
......@@ -2360,9 +2364,10 @@ is-path-inside@^1.0.0:
dependencies:
path-is-inside "^1.0.1"
is-plain-object@^2.0.4:
is-plain-object@2:
version "2.0.4"
resolved "https://registry.yarnpkg.com/is-plain-object/-/is-plain-object-2.0.4.tgz#2c163b3fafb1b606d9d17928f05c2a1c38e07677"
integrity sha512-h5PpgXkWitc38BBMYawTYMWJHFZJVnBquFE57xFpjB8pJFiF6gZ+bU+WyI/yqXiFR5mdLsgYNaPe8uao6Uv9Og==
dependencies:
isobject "^3.0.1"
......@@ -2545,9 +2550,10 @@ lodash.memoize@~3.0.3:
version "3.0.4"
resolved "https://registry.yarnpkg.com/lodash.memoize/-/lodash.memoize-3.0.4.tgz#2dcbd2c287cbc0a55cc42328bd0c736150d53e3f"
lodash@^4.17.10:
version "4.17.10"
resolved "https://registry.yarnpkg.com/lodash/-/lodash-4.17.10.tgz#1b7793cf7259ea38fb3661d4d38b3260af8ae4e7"
lodash@4:
version "4.17.11"
resolved "https://registry.yarnpkg.com/lodash/-/lodash-4.17.11.tgz#b39ea6229ef607ecd89e2c8df12536891cac9b8d"
integrity sha512-cQKh8igo5QUhZ7lg38DYWAxMvjSAKG0A8wGSVimP07SIUEK2UO+arSRKbRZWtelMtN5V0Hkwh5ryOto/SshYIg==
lodash@^4.17.4, lodash@^4.3.0:
version "4.17.5"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment